miércoles, 17 de diciembre de 2014

Problemas para los usuarios de android 2.3

En el post anterior comentábamos los "peligros" de añadir nueva funcionalidad. Si antes hablo, antes ocurre. El domingo lancé una nueva versión y ayer (día 16-12-14) tuve un informe de error de un usuario que usaba la versión 2.3 de android.

Alguno pensará que la versión 2.3 de android es muy vieja, pero samsumg hasta hace dos años estaba sacando nuevos móviles con esta versión y usando esta aplicación todavía quedan bastantes usuarios.

En breves habrá una nueva versión para que los usuarios de android 2.3 puedan disfrutar de la aplicación.

sábado, 6 de diciembre de 2014

Almacenamiento externo.

A partir de la versión 2.1.1 se permite mover la aplicación al almacenamiento externo del teléfono (y a tarjetas SD). Muchas veces las aplicaciones no funcionan si se mueven (como el caso de los widgets) pero no era el caso de la aplicación.

Mover aplicaciones a la memoria externa(al menos sin hacer birguerías) sólo está permitida a partir de la versión 2.2 de android y esa es la versión mínima para ejecutar la aplicación).

Los "peligros" de las nuevas funcionalidades

Espero actualizar más a menudo el blog, sobre todo para poder dar más información a los usuarios que usáis la aplicación.

En este apartado vamos a hablar de una frase muy conocida el "si no está roto, no lo arregles". Es lo que ha pasado en cierta manera con la aplicación.

Cada vez que una aplicación falla tenéis la opción de enviar un informe de errores para que pueda ser examinado por el programador. Pues bien, gracias a esos informes he podido darme cuenta:

A partir de la versión 2.1 introduje una librería que hace incompatible la aplicación con versiones de android 2.1. Poca gente utiliza el android 2.1, pero he tenido que dejar sin soporte a estas versiones, google ya no permitía actualizaciones con las librerías viejas.

Me sorprende que Samsumg, hasta el año 2.012, todavía siguiera fabricando nuevos modelos de dispositivos móviles con la versión 2.x. Este es el motivo de que todavía haya dejado el soporte a android 2.2 y 2.3 (eso y que la librería funciona para estas versiones).

Me ha ocurrido que sacando una nueva versión, alguna funcionalidad haya dejado de funcionar y esta ha salido a producción. Pero no puedo resignarme a no actualizar la aplicación por miedo a que esta falle.